'Module Thermal Analysis ROUND 2' simulation project by sadeghir97


#1

I created a new simulation project called 'Module Thermal Analysis ROUND 2':

Trying to see if the module is going to receive sufficient cooling.


More of my public projects can be found here.


Can you create a fluid domain using a Geometry Primitive?
#2

Hi @sadeghir97!

Is this going to be a CHT analysis?

Best,

Jousef


#3

Yes it is! I realize I have to turn on Multi-region zone to do that. The one thing that concerns me is that the geometry importer did some damage to the STEP file. I see some of the cells overlapping with the holders, which isn’t supposed to do that.


#4

Hi @sadeghir97!

Please note that, the CAD should contain non-overlapping solid and fluid parts. Further, the boundary (interface) must be overlapping faces of the same area. A good help might be this doc entry: CHT Electronics Cooling. Let me know if you need any further help!

Best,

Jousef


#5

Hey @jousefm,

I re-imported my CAD as an IGES file, rather than a STEP, which seemed to fix the overlapping solids issue, but I’m still getting an error when meshing. I tried to take a look at the meshing log, but I couldn’t really decipher what the error was. Any ideas?


#6

Hi @Get_Barried & @vgon_alves,

can you help this user? Currently no machine around me.

Best,

Jousef


#7

Hi @jousefm,

Thanks for tag me! It will be a pleasure. Taking a look at the project.

Cheers,

Vinícius


#8

Hi @jousefm, @vgon_alves,

I’ve simplified my geometry a bit to remove the nickel strips and the error seems to have gone away, so that’s good. But I’m losing the holders after I mesh so I’m currently re-meshing to see if it was just a glitch/


#9

Hi @sadeghir97,

First of all, sorry for the delay in response, I had been trying to generate a mesh in your first CAD (with nickel strips), but without success. That geometry have very small gaps between the base and the cylindrical parts which neither a very fine mesh got read.

Therefore, for your new geometry, you are having some errors, look:

In this first pic, the red regions are the overlapping regions

Look with more details:

Still there are some overlapping surfaces (showed in the last pic) between the base and the top of the cylinders.

I suggest you fix it and try again.
Please, give me some feedback if arise another question :slight_smile:

Regards,

Vinícius


#10

Hey @vgon_alves!

Thanks for the feedback. I think you are looking at an old version of this project though. The new version’s CAD looks like this:

And here is the link:
https://www.simscale.com/workbench/?pid=8259148489972126435#tab_0-0

I ended up simplifying the geometry and getting rid of the nickel strips altogether, which actually allows SimScale to mesh, but it’s getting rid of the holders? I’m not really sure what’s going on there…


#11

Hi @sadeghir97,

I got it now, but here is the gap in your geometry that I said before, look

Should not these parts be in contact in your case? These gaps should affect the heat conduction in your geometry.

Regards,

Vinícius


#12

Hi @vgon_alves,

I gotcha. In real life, there is actually going to be a gap for a tolerance, but for the sake of the simulation, I fixed that. I’ve discovered what Is happening to the holders and I’m completely baffled. Maybe @jousefm knows what is happening. The main problem is that I thought the holders were disappearing.

But I ended up retracing which solids they were:

And I discovered that they’re not disappearing, but they’re shrinking to basically a single cell!

I think it might be they way SimScale interprets “multiregion meshes” so I will experiment. If you guys have ever encountered this problem though, did you fix it with mesh refinements?


#13

Hi @vgon_alves & @sadeghir97!

Just to understand your project: Where do you intend to create your fluid and solid domain?

An example for this simulation type can be found in the doc: https://www.simscale.com/docs/content/preprocessing/meshing/hex-dominant_cht_electronics-cooling.html?highlight=cht

Best,

Jousef


#14

Hi @jousefm and @sadeghir97,

I saw that @sadeghir97 obtained successful in the meshing just filling that gaps. Can you confirm that, @sadeghir97 ?

The surface refinement probably will help you with the edges.

You can use a surface refinement here in a range of 2 to 3. I think it will be enough.
Please, update us as soon as you can :smile:

Best,

Vinícius


#15

Hey @jousefm, @vgon_alves

I thought I had a good mesh, but then I realized I didn’t mesh the fluid domain. I thought there was a way to do that in SimScale without having to define it in the CAD. I thought I had meshed the fluid domain because I selected the automatically created Background Mesh Box, but it’s not selectable?

I also tried defining a new Cartesian Box because that is how I’ve done it before and old tutorials I have seen did it.

I think there might have been some sort of update since I last did this because the box I created is not able to be assigned as a refined region?


#16

Hi @vgon_alves, @jousefm, @Get_Barried, @1318980,

I’m gonna move all the messages for the project on this thread.
So I think @1318980 mentioned how I had selected Background Mesh Box in the Region Refinement and that should have automatically meshed a fluid domain, but it didn’t. Am I doing something wrong? The latest completed mesh is titled ‘Final Mesh’ and the mesh currently being generated is titled ‘Last mesh-hopefully.’


#17

@vgon_alves, @jousefm, @Get_Barried, @1318980,

Update: So the last mesh I have completed looks really good:


But I still have no idea why a fluid domain hasn’t been created. The background mesh box that was checked is not being recognized and so it was never meshed. Any ideas?


#18

Hi @sadeghir97, I think I might have misunderstood what you were trying to accomplish. I thought you were trying to create a fluid only mesh. However, if you are creating a multi-region mesh for CHT then you need to create your fluid region in CAD also (ensuring that it is boolean with your other geometry). Re-meshing with the same settings should then give you the desired results.

Hope this helps,
Darren


#19

Hey @1318980,

Sorry yah I should have been more clear. I remember being able to create a fluid domain for a different type of CFD mesh directly on SimScale. But for CHT simulations, you need to define it in the CAD? That sounds a little annoying to do because it needs to be a volume but not intersect any of the actual CAD right? I was thinking about making a solid box, then subtracting the volume of the battery module? Is there an easier way to do it?


#20

Hi @sadeghir97,

Yes, it is an extra step, but this avoids unwanted regions meshing, I suppose an enhancement would be the option to mesh the bounding box. Feel free to add it to vote for features :slight_smile:

This is how I do it, works fine for me :smiley:

Hope this sorts your issue,
Darren