'MeshOnSimscale' simulation project by julesfa


#1

I created a new simulation project called 'MeshOnSimscale':

Use OpenFOAM project with the Simscale tools !


More of my public projects can be found here.


#2

Hi @julesfa, how is the test of OpenFOAM project going? Anything I can further help?


#3

Hi @sijia , we have done in the other project the upload of our case OpenFOAM, it worked ! No we are trying to make a fluid dynamics project with our basic geometry, and to make the mesh directly on this platform.
I don’t know if you see what i’m telling, thanks for asking !


#4

Hi @julesfa, great to know that! If you have any difficulty with the new project, feel free to tag me! Good luck!


#5

Hi @sijia , do you know if we can break a figure to have each face, to can choose the inlet, outlet and the walls, please?


#6

Hi @julesfa

I see that you are using a STL format geometry ( 1 face). To split it into different faces so that you can select the inlet , outlet etc , you will have to apply a ‘geometry split operation’ ; Follow the Forum post below on how to do that.

let me know if this is what you meant.

Best,
Ali.


#7

Hello @sijia , I would like to ask you a question about our project.
When we import our geometry and we do the meshing directly on Simscale, can we select the number of meshs we want?
Thanks for your help !


#8

Hi @julesfa,
I suppose by “number of meshes” you mean the number of elements of the mesh.
With SimScale you can do that indirectly by selecting how fine you want your mesh to be. Fine meshes will produce above 1mln elements, while coarse will end up with several 100k. Then there is the manual mode, where you have even bigger control over the mesh quality and size.
Please check this topic in documentation
Good luck!


#9

Hi @sijia,
By “number of meshes”, I mean indeed the number of elements of the mesh.
I found how I can adjust the fine meshes.
But when I try to use the manual mode, I want to use the function “Tetrahedralization with refinements”, but there is a file format problem and I don’t know how fix this.
If you can help me, I would be grateful.
Thanks !


#10

Hi @julesfa

The Error message you get is self explanatory , it says:
Error: The meshing algorithm currently does not support the file format of the selected mesh base.
Currently supported:
stp, step, igs, iges, brep

The Tetrahedral type meshing algorithm only supports the stated geometry file formats ( i.e stp, step, igs, iges, brep ). Your geometry is in STL format, so it complains.

To use a Tetrahedral type meshing algorithm please import your geometry in STEP, STP, IGES or BREP format. Then it will work.

Once, you have imported a compatible file be sure to give appropriate values for Maximum mesh edge length [m] and the Minimum mesh edge length [m].

Best,
Ali.


#11

Hi @Ali_Arafat ,
The problem is that when we export our figure from the software “Salome” to our computer, there is none of these formats I can choose, except STL format.
So I don’t know if I can transform a format into an other or not.
Thanks.


#12

Hi @julesfa

If you are using Salome 7.5.1 or higher …just > select your solid > click ‘file’ > then export > all options are there.

.

Thats all there is !

Best,
Ali


#13

Hi @Ali_Arafat , in our university we are using Salome 7.4.0 sadly.
Maybe this option is not available in this version of Salome.
Thanks.