SimScale CAE Forum

Meshing Fail: Cell Zones Assigned Using Faces


I am having the exact same issue, and I’m using the model that is used in the Webinar. I’m hoping for updates (:


@jousefm Any insight on this?



Hey guys!

Will reach out to the meshing team and get back to you as soon as possible :slight_smile:

Update: Only Volumes are allowed!




Hey any news on this? Ive been waiting to do simulations.



Hi Dan!

Only volumes can be selected :slight_smile:




Yes I have been aware of this for quite a while. I think what everyone has been wanting to know is HOW to get a volume selection in simscale. When the STL is imported only solid bodies are created and when the MRF zone solid body is selected either in the tree pane or by clicking on the solid, it is always slected as a face.

I have also already tried to click on the “select volume” button on the top toolbar but this does not work.

Does the CAD Geometry need to be changed for it to be accepted as a volume?
Does the STL Data need to be changed?
Am i just not selecting the solid body correctly?

Any help would be appreciated. Maybe add screenshots for other users to follow.




Hi Dan!

We will soon release cell zones for the new standard mesher - you should then get rid of this problem. Regarding the volume selection you can share the project that is affected in your case and I will have a look at that.




Here is the link.

As i had said, selecting the MRF Front Left results in a face selection.

Selecting the volume tool first does not fix the problem. This only selects the whole car solid body


Hi Jousef,

When do you think the issue will be resolved? Because as you know all our FS deadlines are very tight.

Also this is the link to my project that I am struggling with like Dan:



Will get back to you as soon as possible guys, let me check with the CAD engineers.




I believe i have stumbled upon the answer to the volume question, although i wasnt attempting to solve it.

I was trying to do some quick meshing to see the effects of different boundy layer settings (i want to have a good representation of the Y+ value between 30 and 300) and i used the merging script provided by simscale as this saves a lot of time. The merging script just throws all the STLs together but creates a 3D object file as the output shown below.

Normally i merge everything by hand in notepad so all files are saved as TXT files, which i believe converts the face selections to solid bodies. This is shown in the next picture where i merged everything manually and the drop down menu for each entity in the tree is now gone.

This can be seen under the highlighted MRF zone in the picture. This object is recognized as three faces, which, when combined are classified as a volume. This is shown in the next picture.

The MRF zone is now classified as a volume. In the next picture, it is shown with tire removed, that these three faces are:

  1. the front side of the cylinder in red
  2. the depth of the MRF cylinder in blue
  3. (Not shown) the other side of the cylinder

these three faces when selected together create the volume that is needed to have a functioning MRF zone (so i hope)

I will be doing a simple mesh now to confirm this.

Hope this helps



Would be very happy to know Dan - keep us updated.

Something we definitely changed is that cell zones are not allowed on sheet bodies anymore, so it needs to be a closed surface. (@tinaalim & @dschroeder)




My geometry includes closed surfaces and no sheet bodies, but the error is generated because the solver refuses to generate mesh zones using faces. What can I do?


Are you saying not to use the SimScale merger and use alternative methods?


Hey Tina,

Let me check that and get back to you!




My colleague said that you should be able to select a volume. The cell zone must be a region on its own.
If your model has one region (volume) only and you want part of it to be a cell zone you need to modify the model!




So confirmed that this method did in fact create a mesh for the MRF zones.
However I was wrong that the file upload type (3D object or txt document) was the culprit for not allowing volumes.
@tinaalim this is for you.
This is the 3D object file (merged using the merging script) with a working MRF zone mesh

I then uploaded the exact same file as a txt document, - NOT 3D object - and got the same ability to select volumes

**This is the txt document file (merged using the merging script) **

notice how the ability to select multiple faces in the selection tree (as in a volume) is still available.

I then uploaded my original non-working MRF zone file - self merged - as a 3D object file.

And as you can see … the tree pane shows everything as a solid body again. So this 3D uploaded file, self merged, will not be able to have volume selection.

So in the end it appears to have something to do with how the STL file is merged together before upload. Maybe it has to do with the fact that I renamed all the files - within the txt document - and this somehow changed the file to only being a solid body. This is my only guess as the merging script does not change any names within the individual files. It just throws everything together,

I will try a new STL merged file - with changed names within the individual part file but not with the MRF zones to see if the selection tree allows for volume selection.


@jousefm ok now im really confused. I have tried to replicate my previous upload so that i can get the model to have volumes or “solid bodies” as shown here

This is the “colorful geometry” and shows that solid bodies are being identified as well as sheets, shells, faces, edges, verticies. This file was created using the script merger without any name changes.

Now i am trying again to use the merger, no name changes at all, and i keep getting the old “grey geometry” where i cannot sellect volumes. This one has no solid bodies detected, only shells and faces.

How do I need to upload the file so that solid bodies are detected. Should i not use STLs anymore? What would you reccomend for this simulation application?




I tried replicating your process too and I didn’t notice any changes. Sometimes the merger gives me volumes but more often than not it’s all faces.


Hello, my suggestion is to clean the model in the first place. In both cases (colorful and shades of grey), sheet bodies are present, indicating that some faulty entities cannot be fixed.
Let me know how I can be more helpful