SimScale CAE Forum

Mesh and geometry problem

Hello! I am trying to simulate the flow around a racecar. When I insert the geometry everything seems ok, but when i make the enclosure, the surface can not be representated 100% with all its curves.
1)Why is that happening? Will it have an impact on the whole process?
2) During meshing it indicates 2 problems: " Illegal triangles were found after surface tesselation. There could be a problem with the CAD geometry. Trying to proceed anyway." and
“The tesselated surface is not closed. There could be a problem with the CAD geometry (such as self-intersections). Please inspect your geometry. Trying to proceed anyway.” and also an error about the quantity of mesh elements
How could I fix these problems in this particular geometry?

project link:

Hey @StratisXatz

  1. I am not sure why your geometry is not being accurately represented. I have never seen this before, but your mesh looks good so i dont think it will be a problem.
  2. This problem normally comes because you have small faces or intersecting geometry like the error says. I would very closely inspect your CAD geometry. Especially in places where parts are connecting, like where your diffuser meets the MONO for example. Its really hard to find every intersection point but maybe you can use interference tool in your CAD program. I know solidworks has one, and i usually run that before exporting my CAD files. If you do upload a new geometry, it could come in correctly and solve the problem in #1

Dan