SimScale CAE Forum

Many time steps Error and general support

Hi there, I have been attempting to simulate the k-w IDDES simulation for a CAARC building by using the k-w SST model. I get an alert regarding many time steps? I have looked into the documentation and tried to improve this but to no avail. Could someone please help with this.
Lastly if possible could someone be able to provide comments on how i can improve my model in order to attain similar results to that of the original k-w IDDES model please?

Thanks in advance

Link to my project: https://www.simscale.com/workbench/?pid=4228370608098992886&mi=spec%3Ad448a0ff-a537-42ef-a7d6-3e11beb5e3ef%2Cservice%3ASIMULATION%2Cstrategy%3A39

Link to the analysis I am trying to replicate: https://www.simscale.com/workbench/?pid=8916625400151045378&mi=spec%3A562e262e-3f61-40b5-9845-002aa5a737fa%2Cservice%3ASIMULATION%2Cstrategy%3A19

Hello as i see it right in your second case (kw-SST Trial) you have a transient case with a step of 0.005 seconds and an end time of 900 seconds. This would result in 180k steps which is quite much. maybe reduce your time to a few seconds or increase your time step. When that work we can have a look on the differences and see where to improve in comparison to the k-w iddes case.

Best regards Sebastian

Thank you for the help, I attempted to change the set up (see image) but i have the same warning popping up. Is there a different parameter i need to change?

Sam

You can change the write interval to 0.5 or 1 second, as stated in the warning this will reduce the number of exported results and with that decrease the size of your simulation file.

Thank you, I have changed this and the error has now disappeared. I forgot to ask, when I added my custom boundary for an ABL inlet it is not being recognised as an inlet and an error stating not inlet has been assigned appears. (see image)

thank you for all the support!

Since this is just a warning you can ignore it when you boundary conditions are set up properly.

Another option to assign the flow boundary layer is a function control.

You can find out how to do that in this this tutorial.

Best regards Sebastian

1 Like

Hi there, I have attempted to do the adjustments you suggested but when going to run the simulation i get this message, after trying to run the model it was cancelled after approximately 30 mins?


Could this be because the mesh is to fine?

thanks in advance

Sam

Hi Sam,

Yes indeed your mesh is pretty fine, but should still work when you apply the right parameters. (38MioCells.)

Your issue comes from the simulation control settings.
image

Please have a look at the definition of the simulation control settings.

You can also try to copy the simulation control setting from the previous run. They should also work for your new situation.

Best regards Sebastian

Hi Sebastian,
Thank you for the link to the page, it was very useful in understanding each term. I have been trying to lower the run time by adjusting these settings but I still have the following message pop up before running the simulation. Please see the image showing the settings along with the warning message that appears before I run the simulation.

Hi Sam,
this has to do with your setting of maximum runtime of 100s.
This means that after 100s in real time, the project will be stopped. It’s a feature to make sure that your simulation will not run forever if you make a mistake in your setup.
The platform gives an approximated value of the real time simulation runtime., in your case maximum 545 min. (32700 s).

Therefor your set maximum runtime should at least cover that time.

If the expected runtime of your simulation is to high, please consider to reduce the fines of your mesh or the maximum iterations.

1 Like