SimScale CAE Forum

Issue with assigning mesh as the domain


Hi there. I’m trying to simulate an MRF pump and created a mesh out of the geometry. When I try to assign a material to the volume the tree on the top right doesnt show my new mesh but shows the CAD geometry.
as shown in the image below. This will make the simulation take the geometry as a domain and not the mesh.

If I go ahead and assign bc’s on the geometry again because the mesh doesn’t show up in the tree, the simulation error pops up.

I’d appreciate any help and importantly how do I select the mesh as a domain. There’s no selection button in the mesh dialogue box to choose it as a domain. Thank you

Simulation assignment on the geometry is not supported for the currently selected mesh

Hi @anurags

Are you still facing some issue in this simulation coz I saw your project and the “mesh 2 verification 2” simulation is working in the desired manner. If you have any other issue plz don’t hesitate to share with us.



@anirudh2821998 No it is not working. Please see the project titled Centrifugal Pump. The one you saw is just a public project.


Hi @anurags and @sriramchari1

EDIT: Sorry, I couldn’t give an extensive explanatiopn on how I solved this issue as I was busy preparing for my exam. Here is the method I use when I work with MRF problems.

  1. Your CAD will play a very imp. role in the process of formation of a new cell zone. I usually make my CAD model in this format-

    In your CAD models your blades are solid so, my first step was to use boolean cut operation to make that cavity in both the MRF cylinder and the main body. Thus there was no need to make a new assembly from scratch. Then I made a new mesh with MRF zone by using the “with cell zone” option in the surface refinement .

I made some modifications in the CAD model and now the MRF zone has been created properly and it is now able to assign B.C’s to the mesh surface. I am attaching the project link here-

You can either download the CAD model and assign desired mesh refinement in a new personal project or you can simply copy my project and work within it. Hope that helps :slightly_smiling_face:


Boundary conditions assignment to mesh
Mapping of assignments from geometry to mesh failed - MRF

Thanks for reporting this @anurags!

This should usually be no problem, already reported that to our engineers to fix this issue. We will keep you up-to-date about the progress!



I will run it and let you guys know. Thanks again to @anirudh2821998 for the effort.


Unfortunately, I have run exactly into the same problem. my case is here:

I have also tried to modify the case prepared by anirudh2821998, but it has a different problem: the blades have a rough surface * case:

Do you know another way around that issue?

Thank you,


Hi @ephiopia93: Please take a look at small demo project I’ve just created. Internal CFD with MRF. This should allow you to sort out those problems.




Thank you very much for your answer. I have tried to rerun your case, but the same issue occurs: the mesh is not assigned to the domain. In addition, using the method presented by [anirudh2821998] gives a poor mesh quality and crashes. I use all boundary conditions as in one of the examples I found in the public domain, so I suspect the problem is in the mesh. Could you help me with this issue?

Thank you,


Hi Stan,
I do not see, in the posts of this topic, where Retsam provided you a case to run, how were you able to re-run his case?

I opened your case in your post #7 and the first thing I see is that there are still 3 solids, in the only geometry, in that project.

In Retsam’s Post #8, he shows you a project that he created to help people currently having a problem with internal MRF simulations. Currently you must follow his recommendations and if you did, you would have only 2 solids in your geometry.

Please modify you geometry accordingly and try everything he suggests in his sample project…



Hey guys!

The issue has been resolved and the error message “Mapping of assignments from geometry to mesh failed” should no longer appear. Let me know if you have any further questions.


Hello @anirudh2821998,

During the assembly of body 1 and body 2, wouldn’t the surfaces of of blade cavity in body 1 overlap with the surfaces of blade cavity in body 2? So, though the surfaces will be joined to each other , they still act as two different surfaces. How to provide boundary conditions for both the surfaces, to make them act as one?

Thanking you.

Yash Agiwal.



I still appear to be getting that error when I try to run a simulation on this project!

I am trying to follow the tutorial posted here: Session 4: Contamination control of a Clean room



Hey Goku (cool name by the way :wink: )!

Can you please set your project to public - it is still set to private at the moment. We will have a look at that.





I believe the project is already public:




Hi Goku!

Was a problem with the project name that it converted the link incorrectly. So I do not see any problems (let alone errors) inside your project - can you tell us what the issue was?




Hi Jousef,

I was following the tutorial that I linked above, and set all of the values as it said to. But, when i tried to begin a simulation i got these two errors:

I am not sure on how to resolve the second error.



Thanks for reporting this Goku!

Will forward that to our engineers - we will tackle this as soon as possible. Getting back to you when I know more.

Have a nice weekend!