SimScale CAE Forum

Importing a multi region mesh from OpenFOAM


#1

Hi all,

has anybody successfully imported an openFOAM multi region mesh to the SimScale platform? I tried to upload a standard openFOAM mesh, it all worked fine. The problems start when I want to take into account different regions in that mesh. During the process of splitting the mesh, it is being moved from constant/polymesh into constant/domain0/polymesh and constant/domain1/polymesh. When I now zip the constant folder, upload it to SimScale and chose openFOAM as format, SimScale does not even return an error code. After the upload is finished, the view is just being reset. No new mesh listed.

Question: Is there a way to import an openFOAM multi region mesh? The feature to upload a whole openFOAM case has been discontinued, I believe.


#2

Hi @jbergmeier!

This should work - simply put it into the constant folder and upload it to the platform which is basically the same procedure as with the single region.

Can you maybe show if there is a message (although you said there is none) and also a screenshot if you see some message that is popping up?

Cheers,

Jousef


#3

Hi Jousef, thanks for getting back to me.

I tried again, but it won’t work. The upload goes up to 80%, there it is stuck for a couple of seconds, then the window closes and nothing changed. I waited a couple of minutes and reloaded the page, but still there’s no new mesh, neither any error message.

I compressed the two folders inside the constant folder (domain0/polymesh, domain1/polymesh) in two separate archives and uploaded them separately, then they are being processed just fine. But in two different meshes, which is not what I need.


#4

Hi @jbergmeier!

Please share the folder with me via Google Drive/Mega or any other page and I will test it myself. If I manage to make it work I will let you know.

Cheers,

Jousef


#5

Hi @jousefm

here you can find the archive with the multi region mesh in openFOAM format:
https://drive.google.com/file/d/1CfVxazy9INL-jEefw0o0VpRQZjvP3J9c/view
All the other meshes (whole domain as one region; two seperate regions uploaded as single meshes) can be found in my project:
https://www.simscale.com/projects/jbergmeier/eckardt_compressor/

Thanks for having a look at it!


#6

Hi @jbergmeier!

Also failed for me, let me test some other options and get back to you if I found a solution to that :slight_smile:

Cheers,

Jousef


#9

Hi @jbergmeier!

When downloading a CHT file from our public projects the folder structure looks quite different from yours, below an example of a CHT constant folder that actually works when uploading onto the platform.

Related Project: Heat Exchanger Simulation


Best,

Jousef


#10

Hello @jbergmeier,

I quickly checked. Your mesh upload failed as there is duplicate patch names defined in it. As we need to define the boundary conditions etc based on the patch names for uploaded meshes we only allow meshes that contain unique patch names to make sure that there will be no unexpected results in the end.

In your case “default_wall” is used multiple times if I see this correctly.

Best Alex


#11

Thanks for your suggestions guys! I will keep you updated.


#12

@afischer you were right. I renamed the face properly and finally the import to SimScale was successful. Thanks!