[German Workshop] Step-by-Step (Session 2) - Nichtlineare FE-Analyse einer Flachdichtung


#24

Hallo Jousef,

leider haenge ich fest und komme alleine nicht weiter. Ich bekomme bei der Variante mit 6 Schrauben diese Meldung beim Simulation Run check: “Error: Multiple Slave-Assignments in different contact definitions for the following entities. faceGroupOnGeoFaces_63, faceGroupOnGeoFaces_64”
Ich verstehe, dass ich die gleiche face zweimal in den contacts definiert habe, aber ich weiss nicht, wie ich es aufloesen soll. Es handelt sich wohl um eine Flaeche der Dichtung.
Es macht fuer mich keinen Sinn, wieder von vorne anzufangen, in der Hoffnung, dass der Fehler dann nicht auftritt. Ich will verstehen, was ich falsch gemacht habe und es korrigieren. Dabei lerne ich.

Leider ist meine Zeit begrenzt. Sollte ich den Fehler beheben koennen, kann ich vielleicht das Beispiel mit 6 Schrauben heute noch fertig machen, aber zu einer Variante werde ich nicht kommen. Diese kann ich gerne im Laufe der Woche nachreichen.

Viele Guesse,
Susanne

ETA: Link zum Projekt: https://www.simscale.com/workbench?publiclink=4b892553-d1b3-4019-bcc8-b33612c024ac


#25

Hi @Pleiades,

Deadline ist heute Abend (10.07.2017) um 23:59.

Viele Grüße,

Jousef


#26

Hi Andreas (@atabert) & Susanne (@SRS),

heute Abend um 23:59 ist ja die Deadline und ich bin selbst noch unterwegs. Ihr könnt eure bisherigen Ergebnisse dennoch mit Post-Processing Bildern dokumentieren und mit dem was ihr bis jetzt erreicht habt. Selbst wenn ihr nur zwei/drei Simulationen habt, sollte das reichen. Ich spreche das mit @Milad_Mafi noch einmal ab. Ihr solltet da keine Probleme bekommen.

Viele Grüße,

Jousef


#27

Hallo,

der Deadline bin ich mir bewusst. Leider habe ich keine Simulation, da ich eine Fehlermeldung bekomme, die ich nicht loesen kann, wie geschrieben. Es macht doch keinen Sinn, die Simulation noch 5x aufzusetzen, bis sie irgendwann passt, ohne zu verstehen, was das Problem war. Dadurch lerne ich nicht SimScale sinnvoll zu nutzen. Ziel ist es doch, aus Fehlern zu lernen und sie korrigieren zu koennen.

Mit etwas Glueck schaffe ich es, wenn der Fehler den ich gemacht habe behoben ist, bis zum Wochenende die anderen Faelle durchzuspielen.

Viele Gruesse,
Susanne


#28

Hallo @jousefm,
danke für die Rückmeldung! Meine Simulationen laufen noch & scheinen soweit auch zu funktionieren. Ich hoffe einfach mal, dass sie bis 23:59Uhr fertig werden. Ansonsten bekommt ihr den Link zu den bis dato beendeten Simulationen.
Bitte nicht wundern, dass keine Screenshots in meinem Post-Processing auftauchen; das mache ich mit Paraview offline. Bei der Online-Variante beschwert sich irgendwann mein Browser und streicht aus unerfindlichen Gründen die Segel. :-/

Viele Grüße
Thorsten


#29

Vielen Dank für die Rückmeldung und die Information @jousefm,

Bedauerlicherweise konnte ich den Fehler nicht finden. Jedoch hoffe ich, dass mein Projekt in gewisserweise bewertet werden kann.

Viele Grüße
Andreas


#30

Guten Abend Leute!

@SRS & @Pleiades : Kein Problem. Sobald ich Zeit dafür habe, sehe ich mir das einmal an. Bin bis jetzt leider nicht dazu gekommen. Ich frage Milad, ob ihr dann ein bisschen später abgeben könnt.

@Pleiades: Kein Problem. Kannst du ja dann einfach anhängen. Die Problematik müsstest du dann noch einmal im Detail erläutern und eventuell einen Screenshot anhängen, damit ich weiss was du genau meinst. Wenn es nämlich ein Bug ist, werde ich das reporten.

@atabert: Dein Projekt wollte ich mir auch noch ansehen. Hast du deine Hausaufgabe bereits abgeschickt? Wenn dem so ist, macht das ja nichts. Ich suche dann den Fehler bei dir und wir klären das gemeinsam, sodass du wenigstens weisst wo der Fehler lag.

Euch noch einen schönen Abend und bis die Tage!

Jousef


#31

Hallo @jousefm,

danke für die schnelle Rückmeldung und deine Bemühungen!

Leider habe ich nach vollen 3h Laufzeit bei meiner Simulation mit 2 und 8 Schrauben nun doch noch eine Fehlermeldung bekommen: Newton convergence could not be reached. Possible options to prevent that behavior: Update the tangent matrix more often, increase the maximum number of iterations, use automatic timestepping or decrease the timestep.
Die verlinkte Hilfe scheint auf ne fehlerhafte Einstellung in den Sektionen Numerics / Simulation Control hinzudeuten (?), wobei meine dortigen Werte allerdings aus dem Tutorial übernommen sind und im Fall der 4 & 6 Schrauben problemlos funktioniert hatten. Leider stecke ich trotz Hilfe-Wiki noch nicht so tief in der Materie drin, als dass ich ausmachen kann, woran es nun konkret liegt.

Falls du (oder jmd anderes) ne zündende Idee hat: Ich wäre um jeden Hinweis dankbar :slight_smile:

Link: https://www.simscale.com/workbench?publiclink=24afc6c6-3d6e-4e53-890e-4870a6b0826b

Viele Grüße
Thorsten


#32

Hi @Pleiades,

interessant. Werde ich mir die Tage mal ansehen (bin gerade noch dabei auf Prüfungen zu lernen ;)). Falls du dennoch deine Hausaufgabe ohne 8-Schrauben-Simulation abgeben möchtest, ist das denke ich okay und sollte keine weiteren Schwierigkeiten bereiten. Versuche nur bitte alles ein wenig zu dokumentieren. Gerne auch Schwierigkeiten, die du hattest und wie du eben die Ergebnisse (auch wenn es nicht alle sind) bewerten würdest.

Danke für deine rege Teilnahme!

Jousef


#33

Kein Problem @jousef , da hab ich Verständnis für - ich stecke auch noch in der Prüfungsphase :wink: Dann mal viel Erfolg und ich warte einfach mal ab, ob ihr aus dem Fehler schlau werdet.


#34

Hallo @jousefm,
die Hausaufgabe habe ich gesten Abend noch vor der Deadline abgegeben. Vielen Dank für deine Hilfe.
Ich freue mich, wenn wir den Fehler finden können.

Viele Grüße und noch einen schönen Abend.
Andreas