Fatal IO error


#1

I have tried several structural test cases both linear elastic and bi-linear plastic including running a tutoral on the burst of an LP tank. In all cases the solution will not run and returns a fatal IO error. The message is “cannote open file mesh.inp”.

Is this something that I’m doing incorrectly or something else?


#2

Hi @matt_ales,
most likely you used the static analysis instead of static analysis - advanced. This is an analysis type that will most likely be obsolete anyways and will be replaced with the static analysis - advanced soon.

I can not find the project you are referring to, if you wish to find out the problem in your analysis setup without changing the analysis type, you can post the link and I’ll have a look.

Best,
Richard


#3

@matt_ales,

the tet-dominant mesh with quad surface mesh is currently incompatible with the static analysis type and fails without a transparent error message. This is already tracked as a bug and will be fixed shortly. In the meantime, as @rszoeke said, either

  • Choose the static analysis advanced analysis type (compatible with quad surface meshes) or
  • Surpress quad elements in the mesh generation

Best,

David


#4

Richard,
Thanks for the reply. The first attempt before I tried the tutorial and
the tutorial were both selected as static analysis-advanced. I have
since done a simpler analysis of a guided bar. The first analysis was
chosen as just static analysis. I did a coarse, first order mesh which
came out as hexes. When I tried to run it I got the same fatal IO error
with the same message about not being able to open “mesh.inp”. I then made
a second mesh which was very coarse second order which came out all tet
elements. This one ran the *static analysis. * I re-tried the first mesh
and got the same error. I then added a *static analysis-advanced, *non-linear
analysis and it ran on the second mesh.

If I’ve copied the link correctly, the link to my simpler analysis is:
https://www.simscale.com/projects/matt_ales/elastic-plastic_bar/

The link to the tutorial that I was trying is:
https://www.simscale.com/projects/matt_ales/tutorial_-structural_plastic_analysis_of_a_pressure_vessel-template-_1/

Thanks

-Matt


#5

Thanks. I’ll try that.

-Matt