'External Flow' simulation project by cmartiso


#1

I created a new simulation project called 'External Flow':

Investigate the external flow over a vehicle model


More of my public projects can be found here.


#2

Interesting model @cmartiso!

Looking forward to see some nice post-processing results from you!

Cheers!

Jousef


#3

Hi Jousef!
Cheers!
Sorry to bother you, but I am currently experiencing meshing problems as such


I tried uploading the file as an IGES file but it wouldn’t let me. So I had to upload it using .step file. Would this be the reason of the meshing problems? Or is it more a geometry problem?

Thank you in advance for your time.
Kind Regards,

Carla


#4

Hi there!

If you have the choice, STEP is the preferred one since it’s superior in terms of the conversion process to IGES. The STL format can only be used for fluid mechanics analysis since only certain meshing algorithms on SimScale support it!

For the model I saw that there are intersections inside the model and I also was wondering why you do not only use one “layer” for your model - that’s a cleaner modeling imho.

If there are any more mistakes I am not aware of our PowerUsers @pfernandez & @yosukegb4 can give you more input here. They have a good amount of knowledge about such problems.

All the best!

Jousef


#5

Hi Jousef,

I didn’t realise there were intersections! Thank you for checking that out! I will change that in the model!

Thank you for your help.
Kind Regards,

Carla


#6

Hi @cmartiso !

I found some solid models with surfaces touching each other in your Vehicle.stp model.

In my experience, models with surfaces touching each other failed to make meshes.
I am not sure that reasons, but the mesher seemed to have failed to set matirial area correctly.

I recommend you to modify your car body model as one simple solid model and export it as a STL file.

Regards,
Yosuke


#7

Hi @yosukegb4 ,

I will try that! Thank you for your help!

Regards,
Carla


#8

Hi @yosukegb4

Sorry to bother you again, I did what you mentioned and created a solid part. I have also tried a few meshing set-ups but I still get regions of with the same problem as before.
Also, in the mesh log I get the following information:

Could you please help me out?

Thank you in advance!
Regards,
Carla


#9

Hi @cmartiso

I am not sure that your log means, because I am not a CAE software specialist, just an engineer of mechanical engineering. I hope someone of @power_users explain about your log.

Anyway, I checked your model “Vehicle 2.stp” and found it is not a solid model,
it is a model of open surfaces with naked edges (pink or purple? color highlighted curves) as shown below.

It is necessary that the geometry model is closed entirely all for meshing.
You should close them up on your CAD software.

Best,
Yosuke


#10

Hi @yosukegb4,

I hadn’t realised they were open, thank you for noticing!
I am currently working on it! Hopefully the mesh will work once this is solved.

Thank you very much for your help!
Kind Regards,

Carla


#11

Hi @cmartiso,

Let us known if you have further issues with geometry cleaning and meshing! :slight_smile:

Bests,
Jani


#12

Hi @jhorv_th @yosukegb4

Sorry to bother again. I managed to modify the CAD and the mesh has improved quite a bit.
However, I still get this region at the rear that doesn’t look great. Is there anything that you might think that can improve it?

Thank you very much for your time and help.
Regards,
Carla


#13

Hi @cmartiso

I copied your project and tried some meshing parameters.


I modified points as followings and the mesh seems getting better to my eyes.

  • Use ‘STL’ format for a geometry ( Not ‘STP’ )
  • Change Surface Refinement Level max to 8 from 7
  • Remove Feature Refinement, name of ‘Layers’
  • Set Material Point Y as 0.5[m]

You can create meshes for CFD using STP format file, but it seems to be limited for simple shapes.
When STP is used in a model with curved surfaces, mesh creations often become strange.
So I recommend you to use STL format model files for CFD mesh creation when using curved surfaces in your models.

Regards,
Yosuke


#14

Hi @yosukegb4

That’s amazing! Thank you soo much for all your help and for taking the time to run my mesh, I really appreciate it!
I will start using STL then. May I ask why increasing the Y of the material point to 0.5m? Is there a reasoning behing?

Thank you again for all your help! :slight_smile:
Carla


#15

Hi @cmartiso

The reason for ‘Set Material Point Y as 0.5[m]’ is just in order to determine the material area without fail.

Best,
Yosuke


#16

Hi @yosukegb4
I am trying the STL file as you said in this post. However, I am getting a wrong length it says that its around 20 metres and its nowhere close to that. How did you manage that?

Thank you for your time and help!
Carla


#17

Hi @cmartiso!

You can scale the geometry inside SimScale with the Geometry options inside the Mesh Creator tab.

Best,

Jousef


#18

Hi @jousefm,

Perfect! That’s great! Thank you for the fast reply! :slight_smile:

Many thanks,
Carla