SimScale CAE Forum

Exceeded CFL

I’ve got this error but I’m not sure how to resolve it: The Courant number (CFL) exceeded the limit of 1. You may experience either instability or bad temporal accuracy. It is recommended to keep the CFL number below 0.7. In order to achieve this you need to decrease the time step.

1 Like


The Courant number is determined by image , where alpha is local speed, delta t is time step and delta x is the distance between mesh elements.
Taking a look at the formula, the easiest ways to fix this issue is by either lowering the time step (in simulation control) or by making use of a coarser mesh. So you can try one of these 2 options to see how it goes.

Furthermore, analysing your simulation control, there are some things you can change. Generally, transient simulations are quite costly in terms of computing time, so very long simulations should be avoided. For your model, the total length is about 0,3 meters and your inlet speed is about 0,3 m/s aswell. So, air takes about 1 second from inlet to outlet. The End time (in simulation control) should, a priori, be at least 1 second and not much more than this.

Let us know how it goes!