Conjugate Heat Transfer, Maximum Iterations Reached

Hi all,

I have been trying to simulate a complex flow using the steady-state (maybe i need transient?) k-omega SST turbulence model, with 2 slightly different models. I have tried many different mesh configurations (using standard or hex-dominant) with some refinements here and there, but alwyas get the error “Maximum number of iterations exceeded when calculating temperature from a thermodynamic potential. This may be caused by low-quality mesh producing unrealistic pressure in a few cells. Inspect fields for large values in the last time step.”. Some of the meshes have been in excess of 12M cells, so I’m unsure simply refining the mesh when I don’t have much time left is viable. Any suggestions?

Thank you

I would not just increase the number of mesh cells but make sure that there are parts of the geometry that need proper handling in terms of refinement. CFD Squad, can you see what our user might do a bit better to achieve a solution?



It must have been an issue with bad cells due to refinement, I did manage to get a run working by reducing the mesh resolution by a factor of 6 or so!

I do have one more question though; in the post-process view I can see the temperature distribution throughout my model, but I would like to change the min and max temperatures shown for the contour cutting plane. The region of interest only changes by a few degrees, but I can’t really see its temperature distribution as there is a nearby heat source that runs much hotter. Is there any way to change the contour cutting plane min/max values?

Thanks again


If you’re referring to the scale bar, there is a way. Just click on the scale bar and some extra configuration options will appear. You can change the scale range to manual and adjust.

1 Like