Can't Import STL


#1

I can’t seem to import STL files no matter how simple or complicated they are. I keep receiving the error “Upload of file ‘test.stl’ failed: Unsuccessful server response code of: 400”. I can’t find any previous posts on the forum with this error code. I’ve seen response code of 500, but not 400.

Help?


#2

Hi @hydin,

STL files should be able to be uploaded. However, I’ve also encountered problems with STL geometries myself and prefer to work in other formats, namely IGES.

While I’m unaware of a method to fix the STL file such that it is able to upload, there are several ways to covert the STL file to a more friendly format. Maybe someone here can have a fix for the STL upload but in the meantime, I will detail out how to convert the STL file.

The first method is the way I usually use. However do note you need AutoDesk’s AutoCAD for this method. Convert your STL file to DWG via this link, then import it into AutoCAD before exporting the model as IGES for upload. Be sure to select the IGES format when uploading.

Another method is to use Onshape, but Onshape has similar issues with STL files from what I’ve experienced. So you can try to use the previous link to convert to DWG and upload it to Onshape to then export it to SimScale. I haven’t personally tried this method so if it works do let me know. An easier way since you don’t need any additional CAD software other than Onshape which is in the browser.

The last method is to mesh the geometry via a third party mesher and upload that to SimScale. This saves you from needing to upload the geometry in the first place but you need third party software to manipulate and mesh the geometry which is less than ideal.

Hope this helps!

Regards,
Barry


#3

Thanks for the reply. I tried the OnShape route but it requires me to pay in order to upload any files, so that’s a no go.


#4

@hydin

Could you send me your geometry by uploading it here? There is a “Upload file” option in the forums tab so see if you can upload it.


#5

I wasn’t able to upload it from the forums because it doesn’t accept .stl files, however I put it in my Google Drive and have a share link.

https://drive.google.com/open?id=1MMg_vNefLEdFa1HzgTlZPLgs8LzTtQEo

Thanks for all your help so far.


#6

Thanks! Will see if I can get it working for you.


#7

Hi @hydin,

Onshape wasn’t cooperating with DWG files so I guess there goes that method.

I’ve reverted to my old way of exporting it out of AutoCAD and you will find it here as an IGES file. Do let me know if it works.

Also please do check the scaling. AutoCAD sometimes does some funny things with the scale that I might miss so do let me know if its problematic. Otherwise you can rescale it yourself if need be.

Cheers.

Regards,
Barry


#8

It uploaded just fine. Thanks again for your help. :smiley:


#9

Hi all,
I’m having exactly the same issue.
I’m going through the session 4 exercise of FSAE course.
I cannot upload any stl file (even the original one with the main geometry of the car, which is a file I didn’t modify)
I get the same error 400 thing.
Please help.
Thanks


#10

Hi @AlexFernandes and sorry for the delayed response!

Can you share a Google Drive link (or anything similar) with us including your geometry? We will have a look at this issue and get back to you with a solution as soon as possible.

Cheers and enjoy your weekend!

Jousef


#11

Hi @jousefm
Here is the link

https://drive.google.com/drive/folders/1imHXX_6GpgS7ugYqOp565TGEV2mr10w5?usp=sharing

What worries me is the fact that I try to upload your original geometry (so literally the car without the wing) and even that is failing.
I could be wrong but that tells me there’s something else here going wrong.


#12

Hi @AlexFernandes!

Tested for “S4_home_work_full.stl” and it works for me. Do you want me to share the project with you? Maybe you can post a screenshot of the message and tell us which of the files does not work (I just randomly picked one to quick-test).

Cheers!

Jousef


#13

Yes, since you already have it in the Simscale platform, please share with me the project and I’ll carry on from there.
Thank you so much!
Have an excellent weekend!


#14

Invited you @AlexFernandes!

Thanks and you too!

Jousef