SimScale CAE Forum

An entity name with more than 24 characters was found


#1

Hello,

I am very new in SimScale and I have problems running my simulation. I want to calculate the local heat flow on a planetary surface, so I have started with a very simple geometry to carry out a first test and I have followed the Thermal Analysis Tutorial step by step.
This is my project: https://www.simscale.com/workbench/?pid=4411223043849453753#tab_0-0

Apparently, I imported and meshed the geometry successfully, but when I run the simulation I got this warning:
An entity name with more than 24 characters was found. This is not allowed for the Code_Aster solver

Then, the simulation stops. I have also found this error in the Simulation Run Even Log:

groups edgeGroupOnGeoEdges_22810 and edgeGroupOnGeoEdges_22811 !
! have same twenty the first four characters, their name !
! short is thus edgeGroupOnGeoEdges_2281. !
! As it is not legitimate in the general case that two !
! groups with the initially different names are amalgamated,!
! computation stops.

Any help in resolving this issue would be greatly appreciated.
All the best,
Isa.


#2

Hi Isa (@isaegea)!

Is the part you are using in STL format? What I can think of at the moment is changing the names inside a text editor to avoid this issue. I am not at a computer at the moment but I could try it later on and get back to you if that’s okay. In the meanwhile my colleague @rszoeke might give you additional information on the error.

All the best!

Jousef


#3

Hi Jousef!

Thank you for your help!! I used IGES format, but I could change the format if STL is more appropriate.

All the best!
Isa.


#4

Hi @isaegea,
the error happens because you have a rather large model with more than 10 000 edges,
so the automatically generated entity name "edgeGroupOnGeoEdges_22810"is longer than 24 characters, which the solver can’t handle.

There should actually be something in place to prevent that. We will investigate why it did not work in your case.
I’ll update you as soon as we found the source of this.
Best,
Richard


#5

Hello @isaegea,
we tracked down the root cause. Until the fix is shipped, you could overcome this problem by modifying your model such that it is “better suited” for simulation.

I guess your initial model comes from some sort of tessellated geometry, like STL, hence you have many small triangular surfaces which are not necessary to describe the shape of your geometry (essentially it is a box with a few small bumps).
If you could reduce the number of these triangular faces, the simulation should work easily and you would also be able to generate better meshes for the simulation.

Best,
Richard


#6

Hi @rszoeke!

Thank you very much! I will try to find a way to reduce the number of triangular faces. However, I am not sure if I can do this in all the regions that I want to study. If I reduce the number of triangular faces, I lost topography resolution, and that could be a problem in some cases.

I wonder if I could solve this by dividing my volume in two sub-volumes. One of them would be a thin volume with the small triangular faces to model the topography. Under this volume I could use a simpler one (without triangular faces) to model the crust. In this way, I could avoid every small surface generating a small volume down to the base of the crust. I guess this might simplify my geometry. Am I right? Besides, I don’t know if the contact between volumes could affect the solution.
All the best,
Isa.


#7

Hello,
I have the same problem Isa had before. The simulation runs stop due to a problem with an entity name with more than 24 characters.
This is my project: https://www.simscale.com/workbench/?pid=7480278289302701489&mi=spec%3A24bb814f-69f0-4cdd-87b5-56e9a945bc4e%2Cservice%3ASIMULATION%2Cstrategy%3A8

I would appreciate suggestions and help very much!

Sincerely,

Carlo


#8

Hi Carlo!

That is only a warning that you can ignore - mesh groups have been renamed automatically. The solution to this is the following:

  1. Choose again MUMPS

  2. Post-Processing option from “Automatic” to “Active”


Let me know if that helped.

Best,

Jousef


#9

It worked.
Many thanks for your proper and quick help!

Sincerely

Carlo