'Aerodanamic Analysis of the TSC-03E' simulation project by L3br4nd


#1

I created a new simulation project called 'Aerodanamic Analysis of the TSC-03E':

CFD-Simulation of 2015s Formula Student Car of Team Starcraft e.V.


More of my public projects can be found here.


How to Split an STL geometry into different faces
#2

I cannot figure out why the parametric hex meshing process is not ready to start. Every refinement and all the geometry primitives have check marks in front of them so they should be ready (parametric hex mesh DA). I can’t find the missing part. I tried deleting all the refinements but that did not help ether (parametric hex mesh EA). Does anyone see what I did wrong


#3

Hi @L3br4nd - just saw you message now, were you able to get the meshing resolved to your liking? In the future - it’s better to post questions with your project link in the #community-support-and-collaboration or #using-simscale categories in the forum so everyone can jump in and help

Best,
Anna


#4

Hi Anna,
thanks for your reply. I was able to get it meshed using an .stl
model but I could not get the .step Version to work. I guess
simscale converts the model internally to .stl since the
snappy-hex-mesh tool (from OpenFoam) originally only works with
.stl files and the model is either too complex so the model gets
too big or the Conversion produces errors…
I think the mesh I generated using the stl files should be
sufficient.

regards
Sven

#5

@L3br4nd, this is interesting. We typically recommend using solid .stp files for the geometry upload as it’s the most robust for meshing. Although .STL will be fine for an external aerodynamics case.


#6

OK, maybe my mistake was that I created the .stl file from a surface model. I used the surface model because it is easier to simplify.


#7

Hello,
I have another Problem concerning my meshing-attempts:
The final Log entry said always at least:

“Finished meshing with 1 illegal faces (concave, zero area or negative cell pyramid volume)”

when I set up a parametric hex mesh.
In that case it was a “face with face twist <0.01”. Is there a possibility to view the “illegal” cells so I can see where I have to improve my CAD-model? That would help me a lot.
Thanks in advance


#8

I used to have similar issues creating the Steps and the solution was to ensure that when exporting you clicked on exporting the solids and not just the surfaces. Your error seems to be a CAD issue indeed, whats your CAD software?


#9

Hi,
I’m using SolidWorks. Unfortunately I converted the assembly into a surface model because it allows easier defeaturing. I could try to convert it into a volume-part again, but that won’t be easy. Another Possibility is to start all over again with the defeaturing but it took me a whole lot of time to get this far…


#10

Uhm, Maybe you could try to create an extrusion and then use your surface model along with the combine tool to substract it from the extusion. This would leave two bodies behind, the inside volume and then the extra material from the extrusion that you simply need to erase. All this would be done in solidworks and should be fairly quick.


#11

It seems it is not possible to use the combine-tool to substract a surface from a solid… But thanks for the suggestion, I’ll see what other features it offers to help me find a solution.


#12

I know this can be done, maybe its a combination of knit and thicken operations or something. I have been in similar situations in the past and eventually I have always found a way to make it work! Good luck!


#13

Never mind. thanks to you I discovered that there is a defeaturing-tool which did the work that took me several weeks on the surface model in one day on the solid.


#14

Now I know why I used the surface model instead of a solid:
When using solids the files become very big (step~80MB, stl~300MB) and it is not possible to upload files bigger than 300MB and when using the stp-file the mesh-generator runs out of memory…
The Surface Models are 1/10th the size of the solids…


#15

Uhm, one of the things I have found about SIMSCALE is that many times the errors you see are not really caused by what they claim. I tried looking at your project but the browser kept crashing on several geometries and I couldn’t really tell which one was the “good one.” From what I saw, it appears you have managed to thicken the geometry but not really filled in on the inside. This might still work so long as you make the figure airtight. One suggestion I have for you is to merge all the different parts into one, for CFD multibodies are usually not needed but it will simplify things a lot.


#16

Yes I figured that, too. It is now filled on the inside and when I use a coarse stl file as input and don’t mesh it too fine I get the errors down. But what do I do if the Y+ is still too high?
I have the feeling that the meshing produces the more errors the finer I set the refinements. Until now I always thought it would be the other way round…


#17

I should have used the geometry checking tool from SolidWorks earlier. That would have saved me a lot of time and guessing…


#19

Hi @L3br4nd you must be able to run simulation with this mesh. I would recommend to run steady state simulation since it will take less time and for most of the cases its enough to do steady state analysis. Try to keep boundary conditions as simple as possible initially, once simulation converges then move to the actual scenario. For reference just look into this project. let me know if you face problems in simulation.

Best


#20

Sounds like you may have overcome the meshing challenges, however if I can add a comment, in the case the point has not been explicitly made yet. In SW (and CAD in general) you want to keep the geometry as a solid at all times, and for external Aero, you want to get it down to a single body, and then remove that body from the “air box”. Remember, we are solving for fluid flow, so we really want to mesh the volume outside of the vehicle, not the inside.

To get a single body for the FSAE car in SW, save the assembly as a part file, this will produce a “multi-body” part. Open the part up in SW, and then consolidate to a single body part using a series of Boolean features (rarely is the geometry clean enough to just use a single combine feature). If, at some point, you end up with a mix of surfaces and solids, then there is a “cut with surface” feature that @oscarcorripio mentioned, but for it to work well, then geometry must meet certain criteria. Once you have a single volume representing your vehicle, then import it into Simscale using a *.stp file format.

When using this process, any troubles with consolidating the assembly to a part can easily be addressed within the CAD tool, and typically it is due to sliver volumes, small gaps, and point contact between parts where the cross section becomes zero. These issues will cause you meshing errors whether it is a part or an assembly, but when it is brought in as a single part, the file size is smaller as well. I hope this helps.


#21

@fastwayjim: Thank you. Everything your said is right and was somehow clear to me and for the meshes I created in the beginning of August I already worked in the way you mentioned except for some problems:

  • The combining of all the parts into one part seems to be forbidden in SW. When I try to combine everything (not at once but already combined bodies) it says that it is not possible to combine all bodies within a part file into one body. So I ended up with four bodies in one part file.

  • I did not have any small gaps or point contacts in my part. The latter would cause errors in SolidWorks so I am definitely sure about them and I simplified the model wherever I could to close any gaps. I am not sure what you mean with sliver volumes but I think I addressed that, too.

  • Small edges however cause problems: I do not know where they come from since some of them are placed on spots and shaped in a way that it looks like someone cut into the part using a microscope. But I do not think that that is what happened. Luckily it is enough to repair the smallest ones up to 0,03mm.

But in the end I was not able to mesh .step-files using the refinements I needed. But using .stl files and splitting the surfaces to set the refinement settings worked out so I can work with the meshes.