3D display lighting / black model


#1

Hello,
when in the mesh editor, my model is almost entirely black, as if there was only 1 light, some zones get lit only when in the correct orientation.

In the simulation designer, the model is completely black no matter the orientation so e.g. I cannot see which face I select for applying a load.

The display in the post processor works well.




I’m running Iceweasel (Firefox) 38.5.0 on Debian. The same happens with Chromium. 3D display on other websites (e.g. Onshape) works well.

Thanks for your help,

Ben


#2

Hi Ben @bgraf,

thanks a lot for the screenshot and hinting to this issue. From what you write, I think the display problems in the simulation designer can be traced back on that this is a rather fine FEA mesh. By default if you have a mesh in the 3D viewer its element edges are visible, to a allow you to check on the mesh fineness and quality, see this screenshot:

If you have a really fine mesh and a small screen, the black element edges can make it very hard to see what is selected. Typically I only have the element edges turned on immediately after the mesh was generated. For the rest of the setup I turn them off using the viewer options at the top. Having the element edges turned off, your mesh should look like this:

which makes it easier to interact with it. Does that solver your issue at least in the simulation designer?

What’s odd is your first screenshot where the model indeed looks darker than it should. If I open it up, it looks normal to me:

I filed an internal issue and a developer will look into it! Will keep you posted.

David


#3

Hi David,
thank you for your reply. I don’t think this is related to the mesh size, as it is not that fine, this is how it looks in wireframe mode:




The same happens on the project details page, the thumbnails are ok but the display not:

Tell me if you need more details about my configuration.

Ben


#4

Hi Ben,

I took a look at your project because I was interested to see the rendering problem you are experiencing. Everything looks okay from my end but I noticed a problem with the set up of your simulation. I can see that your mesh is too course to adequately represent the stresses that will be generated from the loading. Any plate in bending should have at least three elements through its thickness. Alternatively, you can use one element though the thickness with a second order mesh.

I’ve made a copy of your project and run two alternative simulations to demonstrate the difference. You will see that the course first order mesh greatly underestimates the actual stress.

The public project can be found here

I hope this helps.

Any questions? Please let me know.


#5

Hi @BenLewis,
I guess the display problem is really linked to the configuration on my PC.

Thanks a lot for these explanations ! Glad I made this error at the beginning of using simscale.


#6

I found the website http://www.doesmybrowsersupportwebgl.com, this is what I get :

Maybe this info can help?

I just tried on my mobile phone, the part is displayed as it should. These are the difference I could see in “Supported extensions”:
Only available on my phone:

  • WEBGL_compressed_texture_atc
  • WEBGL_compressed_texture_etc1
  • MOZ_WEBGL_compressed_texture_atc

Only available on my PC:

  • WEBGL_compressed_texture_s3tc
  • MOZ_WEBGL_compressed_texture_s3tc

#7

Hey @bgraf,

I would actually be surprised if the problem relates to firefox as it is the browser which supported webgl I think since version 4.0 and we are now at I think 38. I could imagine that this is somehow related to your graphic card and debian using often very old versions of the drivers for I guess robustness reasons.
Unfortunately I didn’t manage to run debian from a live-stick in a first try. It seems to be more complicated than e.g. in ubuntu. So I could not test it on my computer so far. If you have an unused USB-stick you could try running ubuntu from that and test if it works on your computer.

Best Alex


#8

Thanks @afischer, I’ll try with a Ubuntu live stick, so I’ll know if my graphics card + linux works for Simscale.


#9

I just tried with a Ubuntu live-USB stick, the display is as it should. I’ll see if I can install other drivers on Debian. Thanks for the help !


#10

Hello @bgraf, thx for the feedback. If there occur any issues pls let us know! Best Alex